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Chapter 1 –  Creating a low-cost GPS collars utilizing Mobile Action 

igot-U 120 travel and sports loggers and traditional leather working 

tools. 

 

https://search-proquest-

com.prxy4.ursus.maine.edu/docview/2053259317?pq-

origsite=summon 
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Chapter 2 -  Setting up Mobile Action i-gotU 120 travel and sports 

loggers for data collection 

Step 1. Download the Mobile Action igot-U software @TRIP PC (97 MB) from  

http://global.mobileaction.com/download/i-gotU_download1.jsp 

 

Step 2. Install the Travel & Sport Suite software (Typical)  

 

 

Step 3. Create the following folder on your C drive : 

C:\GT_DATA_LOG 

 

 

http://global.mobileaction.com/download/i-gotU_download1.jsp
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Step 4.  Open the software by clicking on the @Trip PC icon  

 

The home screen will look like this  

 

Step 5. Plug the included USB cord into the computer and   attach the i-gotU GPS device. You 

will be prompted with the following pop up box to log GPS data, click YES. 

Note – the metal connection pins on the device can build up a level of corrosion when left on 

range for extended period of time and this will cause a poor connection. Take a pocket knife or 

fine sandpaper and clean the connections if the computer fails to recognize the device.  
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Data is now saved as a .csv file in  

C:\GT_DATA_LOG 

 

Rename the file – Processing GPS data creates a lot of folders and files. Take this opportunity to 

begin storing information in an organized fashion.  

I suggest naming the file by (Location_timeperiod_collarnumber_animalID) for example, this 

example is from a research study at the University of Arizona’s V-bar-V ranch in 2015 from 

GPS collar #17 placed on cow 5209. ArcMap (a program to be used later for further data 

processing) does not like spaces or exceptionally long file names, so use underscores. 

 

Once you have downloaded data from all collars and renamed the files, move them to a new 

folder location. 
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(Optional)  

Utilizing @trip PC to look at individual animal data 

Plug the included USB cord into the computer and   attach the i-gotU GPS device. You will be 

prompted with the following pop up box to log GPS data, click YES. When you are prompted to 

create a trip, select “Create a trip” and click Next> 

 

 

 

 

 

 

 

 

 

 



9 
 

The following screen will appear. Do not click or de highlight any selected data, simply press 

Next> 

 

The following screen will appear. Rename the trip to easily identify it later. Once you download 

more than one trip, the number ID generated by the program will easily be confused the 

following trips.  
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Select which ever template style you prefer. I generally utilize classic style. Sporting style will 

show extra information such as elevation and speed.  

The following screen will appear. Select the appropriate time zone and click Next> following by 

Finish 

 

You can now view your trip on Google Maps.  
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Or Google Earth by clicking the following button  

 

 

To save the GPS data from @trip PC, right click the file name on the left side of the screen, and 

select Export to CSV. Please note, you only get the basic tracking data using this method, and 

you will not get any satellite or error information like the data set saved in C:\GT_DATA_LOG, 

and this data cannot be recovered unless the file is saved from the device to folder 

C:\GT_DATA_LOG 
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Data can be deleted using this button  

 

The GPS unit can be reconfigured or Setup using the following button 

 

Screen 1 – Use this screen if you wish to setup password protection or Reset settings. Click Next 

to advance to screen 2 
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Screen 2 – Utilize this screen to setup manual control (push the button to turn GPS on) or 

Scheduled control (use the software to schedule the device to turn on at precise times of day, 

only record data on certain days or during certain times of day). Click next to advance to the 

manual or scheduled control Screens 
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Manual Control Screen – Select your interval between points. Be sure to DESELECT Power 

Saving mode. Power saving mode puts the device into sleep mode between points and has to 

reacquire satellite signal for every fix. This results in a reduced fix rate which intern leads to lost 

data. Smart Tracking mode allows you to put the GPS into sleep mode if the unit is traveling at 

an increased velocity. For example, it was designed to shut the unit off and save battery when 

you are driving in a car, as opposed to just walking around. I do not use this feature tracking 

livestock, however, it could useful if you wanted to exclude data from livestock being trailered, 

herded, or not at rest.  
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Scheduled Control Screen – Use this screen to schedule on/off times for the device. You could 

use it to turn on the devices after the collars have been placed on the livestock, or use this mode 

to only record data during the day/night/morning/noon/evening time. I could see this being useful 

if you would like to prepare/pack up your GPS tracking collars in the lab so when you arrive at 

the working facility you only have to place the collars on the animals to save time. Or, this would 

be useful in a situation like monitoring sheep behavior when animals are herded inside every 

night and you are only interested in the animals grazing behavior. This data could be sorted in 

excel later, but it would be a cumbersome task.  
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Chapter 3 – Sorting bad data from Mobile Action i-gotU 120 travel 

and sports loggers  

This is a reply I received when I contacted Mobile Action to request more information about the 

data logged by the GPS unit  

Dear Sir, 

Thank you for using Mobile Action products.   

We are sorry, we can only export the data from the GPS device(GT-120), and all the 
calculations are from the GPS chipset itself, we don't understand how it calculate. 
 
Please see the following information we can only explain. 

Please refer to the following steps to get data. 
1. Add a new folder in C disk, folder name is GT_DATA_LOG, then run @trip PC 
program and download trip from i-gotU hardware again. 
2. Please run the Microsoft Excel program to open the data file on 
C:\GT_DATA_LOG, you can see the whole GPS data that we recorded. 

---------------------------------------------------------------- 
. Date: GPS date 

. Time: GPS time, it is local time. 

. Latitude: Please refer to wiki website http://en.wikipedia.org/wiki/Latitude  

. Longitude: Please refer to wiki website http://en.wikipedia.org/wiki/Longitude  

. Altitude: GPS Altitude, the unit is meter. 

. Speed: The unit is meter/hour，This maximum speed of waypoint.  

.Type: -1 is POI point，-2 is start point，-4 is end point. 

. Distance: The unit is meter.   

. Sleep Time: GPS Logger device sleep time. The unit is second.  

. EHPE: Estimated Horizontal Position Error: The unit is cm.  

-------------------------------------------------------------------------------- 
  Essential:  
‘1’ – the waypoint is displayed on the map 
‘ ’ – Blank means waypoint is not displayed on the map. 
If ‘Optimize track’ is enabled in the setting, waypoint filtered out will not be displayed 
on the map, and thus the blank (no value). 

 
 

http://en.wikipedia.org/wiki/Latitude
http://en.wikipedia.org/wiki/Longitude
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Sincerely yours  

Mark Liang 
Mobile Action Service Center also provides customers with easy access to online 
product FAQ that contain answers to commonly asked questions. Should you require 
further assistance, please do not hesitate to contact us via our website contact us 
page within your detail of question and product information please. 
============================== 
Mobile Action Technology Inc. 
Web URL: www.mobileaction.com 
Tel: 886-2-8913-1666 ext 678 
Fax: 886-2-8913-1667 

  

 

 

Step 1 – Open the csv file with raw GPS data  

 

You should have the following columns: Index, Date, Time, Latitude, Longitude, Altitude, 

Speed, Course, Distance, Type, Timeout, MSVs_QCN, Weight Criteria, Sleep Time, EHPE, 

Satellite ID and Satellite.  

Step 2 – Insert a new column between column A and B, label (cow, animal, bull, lamb etc.) Then 

add the animal’s ID number to each row. Now combine all animals’ data into this spread sheet 

(that way you can do the calculations for every animal at once instead of repeating this process 

for every time.) Leave a blank row between every animal (With this blank row, you can use 

Ctrl+Shift+the down arrow key to quickly navigate between animals).  

 

http://global.mobileaction.com/support/support_Faq.jsp
http://global.mobileaction.com/support/support_Contact.jsp
http://www.mobileaction.com/
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Step 3 – To the left of Column A, add a column, and rename this column, ORDER, and number 

each row. Be sure to copy and paste this row as numbers. This column allows you to list every 

cow in order and double check for mistakes when sorting by different columns.  

 

Step 4 -     Beside the Date and Time columns add an extra column and name them Date and 

Time respectively. The original Date and Time columns are in Text format. In the new columns, 

convert them to values. 
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Then format the new Date column to show the date however you prefer and format the time 

column to military time. Once completed, highlight each column, copy and paste it as numbers to 

remove the formulas.   

 

Then delete the “text” Date and Time columns.  

 

 

 

 

Highlight all rows, and use the sort function under the data tab to sort the dataset by date. 

Remove dates that are not included on the study. Re-sort using the Order column. 
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Step 5. Unfortunately, this raw data file does not correct for time zones. In order to correct for 

this, we must combine the date and time.  Insert a column to the right of Time labeled TimeDate 

and add the Date and Time columns together. Save the new column as a value  

 

To the right of the new column add column CorrectTimeDate. In this example, we need to add 7 

hours to the time/date in order to get the correct time and date. Use the following formula. This 

will correct the time of day, and make sure the date is also correct.   = “TimeDate” + (hours/24) 

=F2+(7/24) 

 

 



21 
 

Save the new column as values, and delete the incorrect date and time columns. Add two new 

Date and Time Columns. Under Date use the formula  = INT(“CorrectTimeDate”) to remove the 

time from the date stamp. Under the new Time column subtract the new “Date” column from 

“CorrectTimeDate” to separate out the time. Then Save both as values and delete TimeDate 

column                    =INT(D2) 

 

 

 

Step 6. Insert a column to the right of Time, and label it Time Difference and subtract the 

previous time to get the time difference between points. *Correction. Use formula  

=IF(E3<E2,(E3+1)-E2,E3-E2) to allow for multiple day time differences 



22 
 

 

Step 7. Insert a new column to the right of Time Difference and label it Difference in Minutes, 

and insert the following formula to calculate the difference in time (unit minutes)  

=(F3-INT(F3))*24*60 

 

Step 8.  Copy and paste both new columns as numbers to remove formulas.  

Step 9. Rename column V to “rate” and divide the Distance column by the Time Difference in 

Minutes column to get rate of travel in meters per minute. Then copy and paste the column as 

numbers to remove the formulas.               = M3/G3 
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Note from Dr. Jim Sprinkle  

When you save the GPS data as a shapefile in Arcmap, it scrubs the unique numbers for time 

difference etc. That’s because they need to be saved as text to retain their uniqueness. Here is 

what I did to correct the problem. I added 3 new time columns to the csv file that I saved as 

Excel. Two of the columns were identical to your time difference and time difference in minutes 

column. The other column was a column I called time calc where I copied only the time with 

your formula =value(cells with text time). There was no need to copy date as a value. After doing 

my calculations and getting the rate, converting to values, I exported the time difference to 

Notepad, saved as text, and paste special back into Excel as text. I also had to format that time 

diff column as text in Excel. When I brought the file into Arcmap and saved as a layer it retained 

the time difference and date and time points unique characteristics since they are formatted in 

text. It was very helpful to me when I was deleting points in Arcmap to have unique time values. 

 

Step 10. To the right of the rate column, create a “rate statement”, 

 =IF(“rate”>84,1,0) 

Copy and paste the column as numbers to remove the formula 

 

 

This flags fixes that are traveling greater than 84 meters per minute, the average walking speed 

of a bovine animal. (If you are working with a different species, you will need to find and 

substitute in the appropriate velocity).  
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N. Chapinal, A. M. de Passille, D. M. Weary, M. A. G. von Keyserlingk and J. Rushen. 2009. 

Using gait score, walking speed, and lying behavior to detect hoof lesions in dairy cows. J. Dairy 

Sci. 92:4365-4374, Doi:10:3168/jds.2009-2115.  

Step 11. To the right of the “course” column add a new column labeled Course Difference, and 

calculate the difference in course between each fix absolute values using 

=ABS(L3-L2) 

 

Step 12. To the right of “rate statement” column rename the column to Course Statement, and 

type in the following statement:  

=IF(“course difference” >=100,1,0) 

Copy and paste into numbers to eliminate formulas.  
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This flags fixes that have drastic course changes. You can see bad positions on the @trip PC 

google map view, they look like this. However, there is no good way to identify which point that 

is, or if it is actually good data or the result of a lot of time between fixes.  
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Step 13 - Rename Column Z to “Distance statement”. You now have to determine what distance 

you would find suspect. In this example, I am tracking a cow at 10 minute intervals. So… 

84 m/min * 10 min = 840 meters 

Anything greater than 840 meters is suspect, and I want to flag that data 

=IF(“distance” >840,1,0) 

Be sure to copy and paste as numbers to eliminate formula  

 

Step 14 – Label column AA, “Total”, and sum the previous 3 columns. Be sure to copy and paste 

as numbers to eliminate formula.  
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Step 15. Label column AB, “Statement” and utilize the following formula 

=IF(“total”>=2,1,0) 

This looks at rate, course change, and distance traveled between points and flags them as bad 

data by finding the points that are way off course as shown previously.  

Be sure to copy and paste as numbers to eliminate formula.  

 

 

 

 

Step 16. Highlight all columns, and under the data tab select Sort, sort by statement. You now 

have all the data points listed in order. If you would like to double check them to see if they are 

really bad data, highlight the rows in yellow. Resort by the order column. Then highlight the 

Statement column and use the Find and Select tool under the Home tab to search for 1s. You can 

then look at each flagged data point and determine if you think it is good/bad data based on the 

animals speed, distance traveled between points, and time between points. In the interest of time 

on large data sets, I would simply eliminate all flagged data. Later data analysis will make up for 

distance traveled.  
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Step 17. Save data with appropriate file name so that you can tell the difference between raw and 

clean data.  

 

Additional data cleanup- In most cases, the above calculations will clean up most of the bad data. 

However, in some circumstances, not all bad data has been removed. Typically, you will see 

high estimates for distance traveled or strange elevation/altitude measurements. Also, you may 

see points on ArcMap that are clearly out of boundaries for cattle to utilize.   



29 
 

One method is to order your spreadsheet based on distance traveled, rate, or altitude to find 

suspect points. Additionally, you could use the ArcMap to find and remove obviously bad data 

points (points outside of the acceptable boundaries.) 

I am including a few notes from Dr. Jim Sprinkle on his additional data cleanup 

I deleted points from the raw csv file by finding those points with altitudes that were way off. For 

my data set, it was altitude <1400 and >1900 meters. This let me eliminate about 50 or 60 data 

points over 30 days (taken every 5 minutes). 

I added an extra step in data cleanup. I cleaned up the GPS shape file in Arcmap with the edit 

function. The way I did this was to overlay the points over the World Imagery file I downloaded 

from Esri. With this file, I was able to eliminate waypoints that were clearly outside the pasture 

boundaries. After doing this, I went through each day’s data and eliminated waypoints that 

bounced outside the normal travel rate. I did this by the Selection/Select by Attributes menu 

function. I chose Date = Get Unique Value and chose the date. I then looked at the highlighted 

points and with the identify function was able to identify when the respective point was recorded 

along with its values. Often, there were two points close together in time as they bounced off the 

path. Using the edit function, I then highlighted the point I wanted to delete. You do have to 

make sure to only have one point showing up in blue when you select it to delete or you will 

delete the entire day. After getting rid of the bad waypoints I saved the file, then cleared selected 

features and chose the next day for evaluation. 

After cleaning up the file in Arcmap, I exported the cleaned up file using the Conversion 

Tools\Excel\Table to Excel function when the layer was selected. This new file became the file 

that I used for the Pivot Table summary to prepare my SAS file. 

I added one more calculation to my final Excel file. I added a column called “15 Slope” that was 

populated with =IF(N2 > 15, 1, “”) . This allowed me to call up the sum of 15 slope in the pivot 

table for each day. I then divided this number by the GPS count for each day and multiplied by 

100 to get the percentage of time the cows accessed slopes greater than 15%.  

The above calculation could prove extremely useful, and the methodology could apply to any 

number of calculations, such as high/low elevation usage, time spent traveling throughout the 

day, etc. 
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Chapter 4 – Converting Longitude and Latitude to UTM (Northing 

and Easting)  

To be able to estimate distance traveled for livestock, we need to calculate the distance between 

two points which we can do easily using Pythagoras’s theorem if we have positions in UTM 

(Northing and Easting). In addition, to utilize Arc Map more accurately, using UTMs instead of 

Longitude and Latitude will result in less error because ArcMap will not have to convert between 

extreme units like minutes and degrees to meters.  

You can easily batch convert Longitude and Latitude to UTM using a spread sheet provided by 

University of Wisconsin located here  

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&ved=0ahUKEwiasvu

wy4jQAhWmwVQKHT2YDc8QFggwMAM&url=http%3A%2F%2Fwww.uwgb.edu%2Fdutchs

%2FUsefulData%2FUTMConversions1.xls&usg=AFQjCNE5gDT3aToy0F3g1A4vGIiKamHc6

g&sig2=0aoZK6A-4qIYEAio5ae2QQ&cad=rja 

 

Open the spreadsheet and select Batch Convert Lat Long to UTM 

Paste your Latitude and Longitude coordinates into L2 and M2 cells.  

Be sure to highlight the row N2:AE2 and copy the formulas all the way down through the 

example formulas, and then again till the end of your dataset.  

Take note of Column AE (You will need this number later to import your data into ArcMap) 

Copy and Paste as values the Northing and Easting columns next to the Longitude and Latitude 

columns in your data spread sheet.  

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&ved=0ahUKEwiasvuwy4jQAhWmwVQKHT2YDc8QFggwMAM&url=http%3A%2F%2Fwww.uwgb.edu%2Fdutchs%2FUsefulData%2FUTMConversions1.xls&usg=AFQjCNE5gDT3aToy0F3g1A4vGIiKamHc6g&sig2=0aoZK6A-4qIYEAio5ae2QQ&cad=rja
https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&ved=0ahUKEwiasvuwy4jQAhWmwVQKHT2YDc8QFggwMAM&url=http%3A%2F%2Fwww.uwgb.edu%2Fdutchs%2FUsefulData%2FUTMConversions1.xls&usg=AFQjCNE5gDT3aToy0F3g1A4vGIiKamHc6g&sig2=0aoZK6A-4qIYEAio5ae2QQ&cad=rja
https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&ved=0ahUKEwiasvuwy4jQAhWmwVQKHT2YDc8QFggwMAM&url=http%3A%2F%2Fwww.uwgb.edu%2Fdutchs%2FUsefulData%2FUTMConversions1.xls&usg=AFQjCNE5gDT3aToy0F3g1A4vGIiKamHc6g&sig2=0aoZK6A-4qIYEAio5ae2QQ&cad=rja
https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&ved=0ahUKEwiasvuwy4jQAhWmwVQKHT2YDc8QFggwMAM&url=http%3A%2F%2Fwww.uwgb.edu%2Fdutchs%2FUsefulData%2FUTMConversions1.xls&usg=AFQjCNE5gDT3aToy0F3g1A4vGIiKamHc6g&sig2=0aoZK6A-4qIYEAio5ae2QQ&cad=rja
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Chapter 5 – Estimating Distance traveled 

Now add a distance traveled column and utilize this formula to calculate the distance traveled in 

meters between points:  

Northing 1=" N1" Easting 1="E1" Northing 2="N2" Easting 2="E2" 

=SQRT((N2-N1) ^2+(E2-E1) ^2) 

Select the cow number in the first column and press Ctrl+Shift+down arrow, and this will take 

you to the next cow in your list. Clear the contents in the blank space between each cow and the 

first row for Distance Travelled. Since we performed the formula for distance travelled for all 

animals, the first distance travelled measure for each cow is actually the distance between where 

the previous cow finished the study and next cow started the study, so we need to clear the 

contents of those cells.  
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Chapter 6 – Generating Accurate Elevation measurements 

Step 1 – Format spreadsheet for importation into ArcMap. Remove all spaces and symbols in 

column headings. Utilize underscores if needed. Save as a .CSV file.  

 

To avoid any trouble importing files into ArcMap, create a new folder directly on your c drive 

and name it ARC. I use subfolders within ARC to separate locations/ranches. (Once you have 

several studies on your computer, the files become confusing without good organization.) 
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Step 2. Find a Seamless DEM  

Go to  

https://viewer.nationalmap.gov/basic/ 

Select Elevation Products (3DEP), search availability and select the finest resolution 

 

Zoom in on the location using the map to the right, and select the area you need for your study. If 

you are unfamiliar with the location, you can use your data set and Google Earth to find the 

spatial location of the ranch.  

Go to your spread sheet and pick a longitude and latitude from the data set  

 

https://viewer.nationalmap.gov/basic/
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Search for that location on Google Earth 

 

You now have a pinpoint location of the ranch, and you can use this as a reference to find the 

DEM map on The National Map from the USGS. 
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Use the square button selection tool to highlight the area surrounding the ranch  

 

Then click the find products button 
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The next screen will then generate an elevation map, add it to your cart 

 

 Then view your cart, and download the data 
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Extract and save all the files contained in the download to your C drive, ARC folder, and ranch 

sub folder  
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Open ArcMap, and create a new blank map 

Under File, click Add Data and select Add XY data 

Select the CSV spread sheet you created earlier 

Set X to Easting 

Set Y to Northing 

Leave Z blank 

Then click EDIT, under Projected Coordinate system, Select UTM, then select NAD 1983, and 

finally, select the appropriate UTM zone. In this example, which is in New Mexico, 12N is the 

appropriate zone. If you are unsure which zone, utilize the batch convert long lat to UTM 

spreadsheet from the University of Wisconsin to identify the zone you will need. Click OK 

 



40 
 

Now the CSV has been added to ArcMap, but it needs to be converted to a shape file to be 

useful.  
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Right click the csv file, click data, click export data, and save the file in the appropriate location 

with a name you can easily recognize  

 

Once the shape file has been added to the map, you can remove the CSV to reduce clutter.  

Then click the add data button and upload the DEM map from National Maps  
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Here is an example of cow data (cleancoltcollars) plotted against the elevation map in ArcMap 

 

Once the shape files and DEM map are in place, elevation can be extracted for all points and all 

animals at once.  

Step 1. Create a new folder within the Ranch and ARC folders named Extraction 
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Step 2. Open Arc Tool Box > Spatial Analyst Tools > Extraction>Extract Values to Points 

 

 

Input Point Features – animal shape file 

Input Raster – Elevation file 

Output Point features – name this file “Elevation” in the newly created extraction folder 

Click >Environments> Processing Extent> change default to Same As Display (make sure you 

zoom in and include all points on your map) then press OK 
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You have now generated elevation values for your points.  

 

Open the “Elevation.dbf” file in Excel – The column labeled RASTERVALU is elevation values 

in meters. Simply copy this column and paste it into your data spreadsheet. Rename the column 

elevation.  
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Chapter 7 – Generating Slope utilization data 

Once the animal shape file and elevation files are in place on ArcMap, generating slope data is 

relatively easy.  

Step 1. Open Arc Toolbox>Spatial Analyst Tools>Surface>Slope 

 

 

 

Input Raster = elevation map 

Output Raster – name the file “Slope” in the ranch folder 

Click Environment>Processing Extent>change default to same as display (make sure your map 

is zoomed in on your points and includes all points).  

Change output measure to percent-rise 

Leave Z-factor as it is 

Press OK 



46 
 

 

A slope file has now been generated 
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Open Arc Toolbox>Spatial Analyst>Extraction>Extract Values to Points 

Input Point features = animal shape file 

Input Raster = slope file 

Save the file as “Slope” in the extraction folder 

Click Environments>Processing Extent and change default to Same As Display 

Press Ok 

 

 

The slope files have now been generated. Open the “Slope.dbf” file in Excel – The column 

labeled RASTERVALU is slope values in percent rise. Simply copy this column and paste it into 

your data spreadsheet. Rename the column slope.  
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Chapter 8 – Generating Distance from Water measurements 

Understanding animals’ interaction with water, especially on arid rangelands, is important 

information for researchers. With the aid of Google Earth, ArcMap, and Excel, numerous 

inferences can be made with regards to animals’ interaction with water. First, we can calculate 

how far an animal is from water for every GPS position. We can estimate how much time they 

spend close to water, and how far they travel from water. We can even determine how often an 

animal visits a water source. This tool also allows you to map out distances from supplement 

sources, riparian areas, barns, trails, etc.  

Step 1. Import a shape file of water sources from the ranch onto the ArcMap with the ranch 

borders, animals, elevation, and slope already open. If you do not have a shape file of water 

allotments, you can generate one easily using Google Earth, Excel, and ArcMap. See below 

Step 2. Open Google Earth. Use a Longitude and Latitude point form your spreadsheet to locate 

the ranch. Search Google Earth for the known water sources. In this example, I have zoomed in 

on a stock tank/pond. Under the tools tab>Options>3D View make sure to select Universal 

Transverse Mercator under Show Lat/Long>OK 

Now hover the cursor over the stock tank and write down the Northing and Easting points in the 

lower right hand corner.  
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Create a short Microsoft excel file with these coordinates and save as a CSV file 

 

Import this into ArcMap File>Add Data>add XY data 

X = easting 

Y = northing 

Z = default 

Then click EDIT, under Projected Coordinate system, Select UTM, then select NAD 1983, and 

finally, select the appropriate UTM zone. In this example, which is in Nevada, 11N is the 

appropriate zone. If you are unsure which zone, utilize the batch convert long lat to UTM 

spreadsheet from the University of Wisconsin to identify the zone you will need. Click OK 
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Once the data has been added to ArcMap, right click the water.csv file, Data>Export Data save it 

as a shape file named water 

 

Once the water shape file has been added, remove the csv file 

Open Arc Toolbox>Spatial Analyst Tools>Distance>Euclidean Distance 

Input raster = water shape file 

Output distance raster = save as “distwater” in the ranch folder 

Output cell size = 5-10 meters 

Environments>Processing Extent> change default to same as display 

OK 
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Now the data must be extracted like Elevation and Slope  

Go to Arc Toolbox>Spatial Analyst Tools>Extraction>Extract Values To Points 
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Input point features = animal shape file 

Input raster = distwater file 

Save it to the extraction folder as “dist2water” 

Environments>Processing Extent>change default to same as display 

OK 

The dist2water files have now been generated. Open the “dist2water.dbf” file in Excel – The 

column labeled RASTERVALU is distance to water values in meters. Simply copy this column 

and paste it into your data spreadsheet. Rename the column dist2water.  
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Chapter 9 – Utilize Pivot Tables in Excel to easily calculate Means, 

Mins, Max, and Counts.  

Tracking data spreadsheets can often exceed 100s of thousands of rows with countless columns. 

Interpreting this data becomes increasingly cumbersome when you cannot simply scroll through 

data. Using pivot tables in Excel easily allows researchers to orientate data in an easy to use 

fashion or make tables of averaged data to run through statistical programs.   

The use of pivot tables is virtually limitless, so I will only go through some basic tracking uses 

For those unfamiliar with Pivot Tables, a basic Microsoft Office primer can be found here: 

https://support.office.com/en-us/article/Create-a-PivotTable-to-analyze-worksheet-data-

a9a84538-bfe9-40a9-a8e9-f99134456576?ui=en-US&rs=en-US&ad=US 

Here is a relatively small GPS dataset with 45796 observations 

 

I am going to highlight the dataset, select the insert tab and press insert Pivot Table  

First, I want to check my fix rate 

Row = cow, Column = date, values = count of northing 

https://support.office.com/en-us/article/Create-a-PivotTable-to-analyze-worksheet-data-a9a84538-bfe9-40a9-a8e9-f99134456576?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Create-a-PivotTable-to-analyze-worksheet-data-a9a84538-bfe9-40a9-a8e9-f99134456576?ui=en-US&rs=en-US&ad=US
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This quickly allows me to see how many positions each collar/cow had each day. In this 

circumstance, I took a position every 10 minutes, so a perfect fix rate would be 144 per day. I 

can divide the actual positions by 144 and get the fix rate for each cow for each day 

 

Next I want to know how far an animal traveled each day 

Row = cow, Column = date, values = Sum of Distance 

Average elevation utilization 

Row = cow, Column = date, values = average elevation 

Min elevation  

Row = cow, Column = date, values = Min elevation 

Max elevation 

Row = cow, Column = date, values = Max Elevation 

These can be repeated for Slope and Distance from Water  

Once you have all the information you need, copy and paste the pivot table as numbers, label the 

rows and columns properly and save as a .csv for importation into SAS.  

You can also utilize If statements  

For example, you want to estimate how much time is spent by water. Add a column besides the 

Dist2water column =IF(“dist2water cell” <200,1,0) excel will flag every point where the cow 

was within 200 meters of water and mark it with a number 1, and any time the animal was 

further than 200 meters away, a number zero. Use the pivot table to quickly average that column 
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per animal per day, and it will give you a percent of time spent by water. You can do the same 

for elevation or slope. For example, percentage of time spent in high or low elevation, or time 

spent on/off challenging slopes.  

If you would like to look at what happens throughout the day you can set the time column to 

military time and add 3 more columns beside time labeled Hour Minute and Second.  

=Hour(“time cell”) will pull out the hour. You can then use the pivot table to summarize the 

animal’s activity throughout the day, every day for all animals.  

 

 

 

 


